Redes-Linux.com
Esta página esta optimizada para ser visualizada tanto en navegadores gráficos, como en navegadores de texto.
 
Buscar en:


 
El Servidor
Current bandwidth utilization 0.01 Mbit/s
Ancho de banda utilizado
 
Redes-Linux
 
Tip Today by ugu.com
 
Más cosas
 
Conóceme
   [Registrarse]  [Editar Perfil]  [Editar sus Preferencias]  [Buscar]
[Mensajes Privados]  [Lista de miembros]  [preguntas]  [Entrar]
Redes-Linux Forum Index » » Redes en GNU/Linux » » No consigo entrar en internet
Ir a la página ( 1 | 2 Página Siguiente )
Autor No consigo entrar en internet
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2004-12-31 18:50   
Tengo instalado el Suse 9.2. Tengo un modem y Suse me lo detecta bien y lo configuro poniendo mi proveedor Euskaltel, usuario, contrasea etc. Pulso el icono de Konqueroor y al poner www.google.com me pone "Maquina desconocida www.google.com". Que puedo hacer?Que me falta por hacer?

  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
nuevo_linux


Registrados: Dec 30, 2004
Mensajes: 2
Publicado: 2005-01-01 19:48   
Bueno con respecto a tu problema, tienes que buscar primero un programa llamado kppp (en linux red hat) que es el programa que te conectara directamente con tu proveedor de internet, una vez conectada, abres tu navegador web preferido y escribes la direccion a la que deseas tener acceso y listo debes tener acceso a internet.

  Ver Perfil de nuevo_linux   correo electrónico nuevo_linux      Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2005-01-02 04:06   
puede ser problemas de DNS?, lo has configurado?

     Editar/Borrar este Mensaje   Responder citando
persono


Registrados: Oct 31, 2003
Mensajes: 585
De: Valencia
Publicado: 2005-01-02 04:17   
Para iniicar la conexin puedes hacer que la conexin se inicie automticamente al arrancar poniendo los valores adecuados en los ficheros de configuracin de los dispositivos de red, los que salen el otro mensaje que te he respondido.

Aunque tambin supongo que desde Yast podrs hacerlo.

Otra manera seria directamente desde lnea de comando con el programa ppp.

Personalmente para mi lo ms comodo es el arranque automtico si puede ser.

Si tu problema es que el mdem se conecta pero no puedes navegar entonces seguramente se debe a temas de dns como te comentan por arriba.

Salud!

_________________
Creo que me voy a quedar con esta firma:
http://www.sindominio.net/ayuda/preguntas-inteligentes.html

[ Este Mensaje fue editado por: persono el 2005-01-02 04:22 ]


  Ver Perfil de persono   Ir al sitio web de persono        Editar/Borrar este Mensaje   Responder citando
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2005-01-03 10:16   
No he configurado el dns. No se como se hace. Yo solo he configurado el modem y no he hecho nada mas.

  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2005-01-03 11:51   
pues configuralos, desde YAST lo puedes hacer y sino, edita a mano el fichero /etc/resolv.conf y metelos ah. Para hacerlo, debers de poner una linea por cada servidor DNS que te haya dado tu ISP, precedido de la palabra nameserver. Por ejemplo, imagina que tu ISP te ha dado los DNS:
1) 123.456.789.123
2) 987.654.321.987
Editamos el fichero /etc/resolv.conf y ponemos las lineas:
nameserver 123.456.789.123
nameserver 987.654.321.987


     Editar/Borrar este Mensaje   Responder citando
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2005-01-03 13:57   
Lo he configurado con Yast(DNS y nombre de equipo). Luego he mirado si ha cambiado el fichero que me has dicho y si que ha cambiado el /etc/resolv.conf. Ahora aparecen los dos servidores, el 212.55.8.132 y el 212.55.8.133 pero no va. A mi tarjeta le he puesto una IP fija el 192.168.1.2. Tiene esto algo que ver para que no me deje salir a internet? Pero es que yo estoy saliendo a internet desde el modem!!!!

  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2005-01-03 17:36   
pero es un modem o es cable-modem?. Si es un modem, ejecuta el kpp como te han dicho e intenta conectar a internet con este.

     Editar/Borrar este Mensaje   Responder citando
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2005-01-03 17:42   
es un modem normal a una linea telefonica

  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2005-01-03 21:09   
En el registro de kinternet me sale lo siguiente:
SuSE Meta pppd (smpppd-ifcfg), Version 1.50 on LINUX.linux.com
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
Status is: disconnecting
Status is: disconnected
pppd[0] died: pppd options error (exit code 2)


  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2005-01-03 21:46   
El error que te est dando es el "error code 2". Este error normalmente suele ser producido porque tienes dos opciones que chocan (incompatibles entre ellas), en el fichero de configuracin de pppd, como has configurado el acceso a internet?, has dicho que tenias un modem interno, verdad?, que modem es?, te lo ha detectado bien, suse?, que tienes en el fichero /etc/ppp/options?...

     Editar/Borrar este Mensaje   Responder citando
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2005-01-03 22:29   
Modem:
-------

Smart Link SmartLink SmartPCI561 Modem
Configurado como modem0 con el proveedor Euskaltel.

Proveedor Euskaltel
Modificar DNS si conectado
Obtencin automtica de DNS
Direccion IP dinamica
Ruta predeterminada



Configuracion de kinternet:
----------------------------

ask-password no
auto-dns yes
auto-reconnect no
auto-reconnect-delay 15
auto-reconnect-exits 8
baud-rate 57600
chat-script wvdial
connection-type modem
defaultroute yes
demand no
device /dev/ttySL0
dial-command ATDT
dial-prefix
dial-prefix-regex
dns1
dns2
endpoint random
idle-seconds 300
ifcfg-filename ifcfg-modem0
init8 ATM1
local-ip
max-number-of-links 1
modify-dns yes
modify-ip yes
multilink no
password <hidden>
phone 909208015
ppp-mode pppp
pppd-options
provider-filename provider0
remote-ip
stupid-mode no
username ioneetxe

En /etc/ppp/options::::

# /etc/ppp/options
#
# Not every option is listed here, see man pppd for more details. This file
# is read by the pppd, it is an error when it is not present.
#
# Use the following command to see the active options:
# grep -v ^# /etc/ppp/options | grep -v ^$
#

# The name of this server. Often, the FQDN is used here.
#name <host>

# Enforce the use of the hostname as the name of the local system for
# authentication purposes (overrides the name option).
#usehostname

# If no local IP address is given, pppd will use the first IP address
# that belongs to the local hostname. If "noipdefault" is given, this
# is disabled and the peer will have to supply an IP address.
noipdefault

# With this option, pppd will accept the peer's idea of our local IP
# address, even if the local IP address was specified in an option.
#ipcp-accept-local

# With this option, pppd will accept the peer's idea of its (remote) IP
# address, even if the remote IP address was specified in an option.
#ipcp-accept-remote

# Run the executable or shell command specified after pppd has terminated
# the link. This script could, for example, issue commands to the modem
# to cause it to hang up if hardware modem control signals were not
# available.
# If mgetty is running, it will reset the modem anyway. So there is no need
# to do it here.
#disconnect "chat -- \d+++\d\c OK ath0 OK"

# Increase debugging level (same as -d). The debug output is written
# to syslog LOG_LOCAL2.
#debug

# Enable debugging code in the kernel-level PPP driver. The argument n
# is a number which is the sum of the following values: 1 to enable
# general debug messages, 2 to request that the contents of received
# packets be printed, and 4 to request that the contents of transmitted
# packets be printed.
#kdebug n

# noauth means do not require the peer to authenticate itself, this must
# be set if you want to use pppd to connect to the internet. In this case
# *you* must authenicate yourself to the peer(internet provider), so do
# not disable this setting unless you are the dial-in server which where
# the peer has to autenticate to.
noauth

# Use hardware flow control (i.e. RTS/CTS) to control the flow of data
# on the serial port.
crtscts

# Specifies that pppd should use a UUCP-style lock on the serial device
# to ensure exclusive access to the device.
lock

# Use the modem control lines.(is default)
modem
# The opposite: local
#
# Description:
# Don't use the modem control lines. With this option, pppd will ignore the
# state of the CD (Carrier Detect) signal from the modem and will not change
# the state of the DTR (Data Terminal Ready) signal.
#
# You need to disable modem and enable local if you want to connect to anoter
# system without using a modem:
#local

# async character map -- 32-bit hex; each bit is a character
# that needs to be escaped for pppd to receive it. 0x00000001
# represents '\x01', and 0x80000000 represents '\x1f'.
# To allow pppd to work over a rlogin/telnet connection, ou should escape
# XON (^Q), XOFF (^S) and ^]: (The peer should use "escape ff".)
#asyncmap 200a0000
asyncmap 0

# needed for some ISDN Terminaladaters, namely ELSA, those seem to have
# problems with asyncmap negotiation, so you can turn off this procedure
# in case your ISDN box has trouble with it, by enabling this option.
# You have to disable the asyncmap <x> option to be sure to have it
# active. If you use wvdial, set the ISDN parameter in /etc/wvdial.conf
# instead.
#default-asyncmap

# Set the MRU [Maximum Receive Unit] value to <n> for negotiation. pppd
# will ask the peer to send packets of no more than <n> bytes. The
# minimum MRU value is 128. The default MRU value is 1500. A value of
# 296 is recommended for slow links (40 bytes for TCP/IP header + 256
# bytes of data). The value 1492 is for DSL connections (PPP Default -
# PPPoE Header: 1500 - 8 = 1492)
# mru 1492

# Set the MTU [Maximum Transmit Unit] value to <n>. Unless the peer
# requests a smaller value via MRU negotiation, pppd will request that
# the kernel networking code send data packets of no more than n bytes
# through the PPP network interface. The value 1492 is for DSL connections
# (PPP Default - PPPoE Header: 1500 - 8 = 1492)
# mtu 1492

# Set the interface netmask to <n>, a 32 bit netmask in "decimal dot"
# notation (e.g. 255.255.255.0).
#netmask 255.255.255.0

# Don't fork to become a background process (otherwise pppd will do so
# if a serial device is specified).
nodetach

# If this option is given, pppd will send an LCP echo-request frame to
# the peer every n seconds. Under Linux, the echo-request is sent when
# no packets have been received from the peer for n seconds. Normally
# the peer should respond to the echo-request by sending an echo-reply.
# This option can be used with the lcp-echo-failure option to detect
# that the peer is no longer connected.
lcp-echo-interval 30

# If this option is given, pppd will presume the peer to be dead if n
# LCP echo-requests are sent without receiving a valid LCP echo-reply.
# If this happens, pppd will terminate the connection. Use of this
# option requires a non-zero value for the lcp-echo-interval parameter.
# This option can be used to enable pppd to terminate after the physical
# connection has been broken (e.g., the modem has hung up) in
# situations where no hardware modem control lines are available.
lcp-echo-failure 4

# Send up to 60 LCP configure-request during negotiation. With a value
# of 2 for lcp-restart below, this might take up to 2 minutes.
lcp-max-configure 60

# Resend unanswered LCP requests after 2 seconds.
lcp-restart 2

# Specifies that pppd should disconnect if the link is idle for n seconds.
idle 600

# Specifies the maximal number of attempts to connect to the server. This
# is useful for dial on demand. Default value is 10.
#maxfail 3

# Disable the IPXCP and IPX protocols.
noipx

# In the file /etc/ppp/filters are some active-filter rules. See man pppd
# and man tcpdump for more informations.
file /etc/ppp/filters

#-------------------------------------------------------------------------
# The next two options are only interesting for you if you are admin of
# a system with other users that use ppp, and those users are normally
# never allowed to add default route, or you do not want users to
# replace the default route.
#-------------------------------------------------------------------------

# enable this to prevent users from attempting to add a default route.
# Use this option with caution: If the user needs to use a program like
# wvdial, he will not be able to connect because wvdial forces defaulroute
# but this is rejected by this option and the user will not be able to
# connect to the internet.
#nodefaultroute

# enable this to prevent users from replacing an existing default route.
#noreplacedefaultroute

#-------------------------------------------------------------------------
# All options below only make sense if you configure pppd to be a dial-in
# server, so don't touch these if you want dial into your provider with
# PPP!
#-------------------------------------------------------------------------

# Set the assumed name of the remote system for authentication purposes
# to <n>.
#remotename <n>

# Add an entry to this system's ARP [Address Resolution Protocol]
# table with the IP address of the peer and the Ethernet address of this
# system. {proxyarp,noproxyarp}
#proxyarp

# Use the system password database for authenticating the peer using
# PAP. Note: mgetty already provides this option. If this is specified
# then dialin from users using a script under Linux to fire up ppp wont work.
#login

# Specify which DNS Servers the incoming Win95 or WinNT Connection should use
# Two Servers can be remotely configured
#ms-dns 192.168.1.1
#ms-dns 192.168.1.2

# Specify which WINS Servers the incoming connection Win95 or WinNT should use
#ms-wins 192.168.1.50
#ms-wins 192.168.1.51


  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
persono


Registrados: Oct 31, 2003
Mensajes: 585
De: Valencia
Publicado: 2005-01-04 01:22   
Has probado a usar dhcp en la tarjeta en vez de asignarle una ip fija?

  Ver Perfil de persono   Ir al sitio web de persono        Editar/Borrar este Mensaje   Responder citando
marta


Registrados: Dec 30, 2004
Mensajes: 22
Publicado: 2005-01-04 14:19   
Es que tengo dos ordenadores conectados con un cable cruzado y he utilizado ips fijas en las tarjetas de red para que estos dos ordenadores esten en la misma red. Despues un ordenador tiene un modem interno a la linea telefonica y esta configurado y en windows puedo entrar en internet,pero en linux no me deja.

  Ver Perfil de marta      Editar/Borrar este Mensaje   Responder citando
LEVIATAN


Registrados: Nov 06, 2003
Mensajes: 309
Publicado: 2005-01-04 16:57   
persono se refiere a que utilices dhcp en el modem, no en las tarjetas de red, para tu red local si que debes utilizar IP fija, a menos claro que configures un servidor DHCP pero para 2 equipos no tendra demasiado sentido

  Ver Perfil de LEVIATAN      Editar/Borrar este Mensaje   Responder citando
Ir a la página ( 1 | 2 Página Siguiente )
  
Cerrar este Tema Mover este Tema Borrar este Tema